INTRODUCTION TO ENVI

Due at end of class.

ENVI (the Environment for Visualizing Images) is a software program that we will utilize throughout the semester to analyze remotely sensed data from satellite and aircraft. The purpose of this lab is to introduce you to the basics of the program.

STEP 1 LOGGING IN

We have purchased a version of ENVI that works on Unix platforms and is currently installed on the envi.wesleyan.edu server. To run the program, you may log on to envi.wesleyan.edu from any Mac or PC using a terminal emulator program such as X11(Mac) or Cygwin (PC). The benefit of this is that you may log in from any computer on campus; however please be aware we have purchased 23 licenses for the entire campus, so please do not leave the program running if you are not using it.

From the classroom (SC 74), launch cygwin to get the envi.wesleyan.edu prompt window and log in. At the prompt, type “startx” to launch the terminal session in a new window. Then type:

```
ssh -Y -l yourusername envi
(if off campus ssh -Y -l yourusername envi.wesleyan.edu)
(for macs, use X11 and type ssh -X -l yourusername envi)
```

after you enter your password, type “envi” at the prompt to run the program.

File Structure

We will place the data for each lab in the following directory

```
datahome/mgilmore/ees226
```

There is a folder in that directory in which you may save work:

```
datahome/mgilmore/ees226/studentsspring12
```

STEP 2 LOADING AND BASIC MANIPULATION OF AN IMAGE

The Mouse

ENVI is written for a 3 button mouse typical of UNIX platforms. I will describe things in terms of the 3-button mouse as left button, middle button or right button. On a Mac or a PC,
you must simulate this according the following rules, however the Macintosh settings on a given computer may need to be reset (I can show you how to do this).

<table>
<thead>
<tr>
<th>UNIX</th>
<th>PC</th>
<th>Macintosh</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left</td>
<td>Left</td>
<td>Mouse</td>
</tr>
<tr>
<td>Middle</td>
<td>Ctrl-Left</td>
<td>Option-Mouse</td>
</tr>
<tr>
<td>Right</td>
<td>Right</td>
<td>Command-Mouse</td>
</tr>
</tbody>
</table>

Opening the Image

Let’s get familiar with the program by loading an image. We will open a Landsat Thematic Mapper data file.

Under File -> Open Image File

Navigate to the envilab directory and select “bhtmref.img”

You will now see the Available Bands List dialog box on your screen. You are in a very powerful position. This list includes the 6 TM bands (conveniently also listing center wavelength). You will now have the choice to display one band as a grayscale image, or three bands as an RGB color image.

For a grayscale image: click on the grayscale button and click on a band to be displayed. The band will appear in the “Selected Band” field. Click “Load Band” and the band will be loaded as a grayscale image. Note to the right of the “Load Band” button you may elect to have the image opened in a new display and thus view two or more images simultaneously.

Once the band is loaded, familiarize yourself with the display group. This consists of the:

Main Display Window, where all or part of the image is displayed at full resolution;

Scroll Window, if your entire image cannot fit in the Main window, it will be displayed herein reduced size. A red box in the window indicates what is displayed in the Main window. Moving this box will alter the Main window display;

Zoom Window, displays an enlarged version of a portion of the Main window, also indicated by a red box and moveable. The number in the title bar indicates the zoom factor, which can be adjusted using the buttons at the lower left hand portion of the window.

1. Select one band and load and greyscale image. What are the major landforms in the image? What characteristics (size, shape, texture, etc., specify) do you utilize to identify the features?

2. After identifying various landforms, look at each band in greyscale. Describe which features appear bright or dark in the various bands (it may be helpful to
display the images side by side for comparison). If you wanted to study vegetation, which bands or channel(s) would you observe?

For a color image, click on the “RGB Color” button. You will be asked to select bands to be placed in the red, green, and blue channels in the display. In this introductory lesson, it is prudent to create an image that is close to what your eyes are familiar with.

3. Which TM bands should you place in the RGB channels to approximate a “normal” color image?

4. Take the time to create various RGB combinations. Based on your answer to question #2, design a color combination to accentuate vegetation and describe it.

5. Which color combination is most helpful to see variations in rock type?

The Main Image Window has a menu with many functions we will utilize during the course. Below are a few that will be important, but I ask that you take time to play around with the options to learn more about the program.

Display Header Information

From the main menu bar File → Edit ENVI Header

This displays the header information for the selected image, including type of data, map projection, and wavelength range. If you hit OK, you will see the Header Info dialog box. This box may be used to edit parameters of the image. In general, we will not want to change these parameters, but we can learn more about the image from this dialog box. Click Edit Attributes and select Map Information. This tells you about pixel size, map projection, coordinates, north direction, and true coordinates of the upper left pixel of the image. Selecting Geographic Corners will give the latitude and longitude of the 4 corners of the image. If you input a non-georeferenced file, you may need to input these parameters yourself.

6. Identify the location of this image in Google Earth.

Display the Cursor Location

Under the Main Window Select Tools → Cursor Location/Value

A dialog box will come up. For any place you click in the windows, this box will tell you the location of the pixel, and the value of the data point itself. If the image is georeferenced, lat/lon data will be provided.
Display Image Profiles

You may display profiles of the data in the horizontal (X-axis), or vertical (Y-axis) direction as well as a spectral profile (Z-axis).

Tools -> Profiles

Now you may select the type of profile you wish to display. The location of the profiles will be indicated on the image by red cross hairs. You may display several profiles simultaneously. Note on the Z-axis plot of a color image, the red, green, and blue lines are present at the wavelengths you specified as RGB in the dataset. The z-axis plot is equivalent to a point spectrum measurement of that pixel and can be compared to laboratory measurements of known minerals in order to identify the composition of the pixel.

In the Spectral Profile window, you may select the option of “collect spectra” instead of the default “replace spectra.” This allows you to plot several spectra simultaneously. In the same menu, “stack plots” artificially separates the spectra for clarity.

7. Select and plot the spectra of several pixels in the scene. Note the relationship between the appearance of the pixel on the screen and how its spectrum appears (note particularly the difference between rock and vegetation). Note that you can change the position of the red, blue and green lines to different wavelengths in the Z-profile resulting in a new RGB image.

Contrast Stretching

Oftentimes it is useful to alter the contrast of an image in order to enhance features of interest. By default, the program displays loaded images with a linear 2% stretch. This is accomplished by pulling down the Enhance menu. A list of predetermined stretch types will be available. You may also specify the stretch by -> Interactive Stretching. A dialog box will appear that contains a histogram of the data values within the image. Vertical lines within the input histogram can be adjusted to control the minimum and maximum values displayed in the output image once the Apply button is pressed.

Scatter Plots

Correlation between regions of different spectral properties can be achieved by creating a scatter plot where one band is plotted against another. This will become particularly important to identify principal components of the image.

Tools -> 2-D Scatter Plots

Within the scatter box display, you may use the middle mouse button to click on a set of pixels. These pixels will be identified on the image. You may also define a region of pixels of interest within the scatterplot by drawing a polygon around the pixels using the left mouse button and closing the polygon with the right mouse button. You can also ‘surf’ around the
scatter plot with the middle mouse button. Other classes may be defined in different colors by selecting a different color under the Class menu in the scatter plot. These manipulations can be very useful, for example, if the scatter plot shows pixels that are outliers, separated from the rest, you may easily attribute those pixels to a particular region on the image. Conversely, you may select a region on the image and those pixels will be highlighted within the scatter plot.

Once you have identified regions of interest, you may export the data and perform statistics upon it. Under Options -> Export All, the data will be listed under the Regions of Interest (ROI) dialog box. Clicking on the “Stats” button will compute the mean and average deviation for each of the 6 bands for the pixel type you have defined. These data will be plotted as a spectrum that is the average value of the defined area and can be compared to spectral libraries to identify composition.

Computing Area

You may make measurements of the image:

Tools → Measurement Tool

In this box you may select a display and window (image, scroll, or zoom) you wish to measure. You may make measurements of line segments and compute areas of rectangles and ellipses. Units of measure are pixels by default; if you know the size of the pixel (e.g., from data type or header info you may convert pixels into other units.

8. Knowing this is a Landsat TM image, compute the approximate area of the irrigation circle and report in m².

Annotating the Image

To place text, scale bars, grid lines, north arrows, etc:

Overlay → Annotation

Select the window and type of annotation from the Object menu. Select the position for your annotation by clicking the left mouse button at the desired site on the image. A red diamond will appear, which is moveable. Type in your text. Adjust colors, line thickness, etc if you like. The right mouse button will fix the position of the image when you are satisfied.

Printing

Instructions for printing to the printer in the SC 74 lab are attached.

9. Please create a grayscale image, put your name, a north arrow and scalebar on it in ENVI, print it and hand it in to me at the end of the lab.
Printing instructions for Web-based printing--PC

1) Click Start—Settings—Printers and select your default printer, if necessary.

2) Open the your application from which you wish to print.

3) After completing any creation work select “the “print” icon on the menu bar or select “File—print” from the drop-down menus in the application. Select the printer for your room SC74_HP5M

4) Click the “Start” button and select the link to the “Wesleyan Lab Printer Web Page” link (third shortcut from the top of the list).

5) You will be brought to the new Web-based printing application site. Enter your network user name and password (same as your PC logon information).

6) You will now see your print jobs listed. Check the box or boxes of the documents you would like printed or deleted.

7) Click on the “Print”, “Delete” or “refresh” button, as you desire.

8) When done with the computer, be sure to log out. This will erase your connection information and prevent others from using your account to print for free.

NOTE: The web page for the web-based client is:
http://labprinting.wesleyan.edu